Asus Crosshair V Audio issue


Home Forums Hardware Audio Asus Crosshair V Audio issue

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #71713
    Devinedragoon
    Participant

    OK I just installed an asus crosshair V a friend gave me and installed the audio drivers which were realtek which i’m nota  fan of.   i can’t get good sound for the life of me -_- i hate realtek audio it has sounds like crap sounds like sound from a $1 pair of headphones no bass  and completely sounds like crap is there any other audio program options for this mothoerbaord outside of buying a soundcard Need some help guys

     

    #90502
    Sir-diealot
    Participant

    A couple of ideas:

    1. Restart the computer and then check for new updates to the program.

    2. Make sure everything is connected securly, it happens, not trying to treat you like you are stupid.

    3. Try different imputs, sometimes this works even though it makes no sense that it should.

    4. Uninstall the program, restart the computer, reinstall the program, restart the computer and then check for updates to the program and if there are updates install them and then restart the computer and check for updates again and if there are not see if it works and try moving the imputs again.

    5. Uninstall the hardware and then reinstall and do everything I listed above.

    I hope it works out for you.

     

    #90504
    Devinedragoon
    Participant

    ​I have a few times will check for missed things, everything is externally have a few inside to double check i think, only 2 sound imputs back sound  no left channel and right sounds like dollar store speakwe quality frosnt is only one that is resaonable atm, 4 seems likes biggest thing, and only hardware is the motherboard as it is onboard audio.

    #90505
    Sir-diealot
    Participant

    ​I have a few times will check for missed things, everything is externally have a few inside to double check i think, only 2 sound imputs back sound  no left channel and right sounds like dollar store speakwe quality frosnt is only one that is resaonable atm, 4 seems likes biggest thing, and only hardware is the motherboard as it is onboard audio.

    Is headset proper Ohms for the imputs?

    #90506
    Devinedragoon
    Participant

    It’s a turtle beach X12 smae headset my old asus mobo used w/o issue

     

    #90507
    Sir-diealot
    Participant

    It’s a turtle beach X12 smae headset my old asus mobo used w/o issue

     

    Ah, your post makes it sound like a new hardware installation to me anyway. Sorry.

    #90651
    Devinedragoon
    Participant

    i tried updating to windows 10 to see if drivers worked better but same  issues so went back to windows 7 after a network issue i couldn’t resolve atm arrose i can change later but for now back to Windows 7. My old usb headset seems to sound fine not sure about the mic as of yet tho

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.